OSPF Area Types - Broadcast

image

In this post and the following posts we will try to explore OSPF network types, OSPF is a core technology in the CCIE lab so you need to be able to configure it without referring to the DoC-CD

In Cisco world, OSPF comes in 6 Network types

1- Broadcast

2- Non-Broadcast

3- point-to-multipoint

4- point-to-multipoint Non-Broadcast (Cisco proprietary)

5- Loopback

We will examine each of these network types over NBMA (Non Broadcast Multiple Access) Media like frame relay network since this is where the confusion coming from.

We will start with the Non-Broadcast networks since it is the default OSPF network when you configure OSPF under frame relay physical interfaces

Initial configurations

R1

!
interface Serial0/0
 ip address 10.1.123.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.123.2 102 broadcast
 frame-relay map ip 10.1.123.3 103 broadcast
 no frame-relay inverse-arp

interf lo0
ip add 1.1.1.1 255.255.255.255


R2

!
interface Serial0/0
 ip address 10.1.123.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.123.1 201
 no frame-relay inverse-arp

interf lo0
ip add 2.2.2.2 255.255.255.255

R3

!
interface Serial1/0
 ip address 10.1.123.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.123.1 301
 no frame-relay inverse-arp

interf lo0
ip add 2.2.2.2 255.255.255.255

Few notes on the cconfigs, note that we haven’t configured any mapping between R2-R3 and we will see how this will affect our connectivity between the spokes

Now let’s configure OSPF

under all interfaces issue this command

ip ospf 1 area 0

You can wait as much as you can but no OSPF neighborship will ever come up!

Simply the OSPF network is Non-Broadcast so OSPF will not be trying to multicast Hello packets, it needs to unicast the Hello packets to a neighbor that you define manually

if we configure the following debug on any of these routers we should should prove that

!
R1#sh access-list
Extended IP access list 101
    10 permit ospf any any

R1#debug ip ospf packet
R1#debug ip packet detail 101
IP packet debugging is on (detailed) for access list 101

Under the Hub R1 we need to define the OSPF neighbors

R1(config)#router ospf 1
R1(config-router)#neighbor 10.1.123.2
R1(config-router)#neighbor 10.1.123.3

Now let’s check the OSPF adjacencies


R1(config)#do sh ip os ne

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:01:59    10.1.123.2      Serial0/0
3.3.3.3           0   FULL/DROTHER    00:01:59    10.1.123.3      Serial0/0

R2(config-if)#do sh ip os ne

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:01:46    10.1.123.1      Serial0/0

R3(config-if)#do sh ip os ne

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DR         00:01:57    10.1.123.1      Serial1/0

As you can tell from the output above, the OSPF adjacencies  are totally mixed up!

R1 thinks that R2 is the DR and no BDR

R2 thinks that it’s the DR while R1 is the BD and R3 is DROTHER

R3 thinks that R1 is the DR and have no idea about R2

This is because the DR role is distribute the routing updates on a broadcast networks, so updates get sent to the DR from different routers on the segment on 224.0.0.6 and then the DR replicates the updates on 224.0.0.6 to every other router on that segment, So by definition the DR needs to have connectivity to all other routers on the broadcast domain, In our case R1 should be elected as the DR

Since DR election is non preemptive in OSPF, lowering the priority of non-DR routers is not enough because they will still participate in DR election, the non-DR routers’ priority needs to be set to zero

R2(config-if)#interf s0/0
R2(config-if)#ip os priority 0

R3(config-if)#interf s1/0
R3(config-if)#ip os priority 0

Clear the IP OSPF process on both R2 and R3

R1(config)#do sh ip os ne

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/DROTHER    00:01:41    10.1.123.2      Serial0/0
3.3.3.3           0   FULL/DROTHER    00:01:58    10.1.123.3      Serial0/0

R2(config)#do sh ip os ne

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DR         00:01:36    10.1.123.1      Serial0/0

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DR         00:01:51    10.1.123.1      Serial1/0

As we can see things are more consistent now, however when we check the routing on either R2 or R3 we will notice that next hob value for their loopback interfaces are their serial interfaces

R2(config)#do sh ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.11.1 [110/65] via 10.1.123.1, 00:11:19, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 10.1.123.3, 00:11:19, Serial0/0
R2(config)#do p 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.
Success rate is 0 percent (0/1)

Since 3.3.3.3 recuses to 10.1.123.3 and R2 doesn’t have a frame relay map to 10.1.123.3 the encapsulation will fail and R2 will not be able to reach R3 loopback and vice versa

To work out this issue without changing the OSPF network, we need to add frame relay map statements on both R2 and R3

R2

interface Serial0/0
 frame-relay map ip 10.1.123.3 201

R3

interface Serial1/0
 frame-relay map ip 10.1.123.2 301

When we test ping now we should have connectivity between R2 and R3

R2(config)#do p 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 112/119/132 ms

Which we do

Last thing to mention on Non-Broadcast OSPF networks is the Hello/Dead Intervals which are set to 30 and 120 sec by default

R2(config)#do sh ip os interf
Serial0/0 is up, line protocol is up
  Internet Address 10.1.123.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State DROTHER, Priority 0
  Designated Router (ID) 1.1.1.1, Interface address 10.1.123.1
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

Comments

Popular posts from this blog

BPDU Filter vs BPDU Guard

BGP Weight Attribute

OSPF–Point To Multipoint Non-Broadcast